Hyper-V backup fails: Cannot start shadow copy - Invalid namespace
 October 23, 2025
	
	
	
			Product Version
AhsayOBM: 7.15.0.8 - 7.15.0.20
      
		Operating System
Windows
      
		Symptom
When performing a Hyper-V VM backup, the following error message is displayed on the backup client interface, or in the backup report:
| No. | Type | Timestamp | Log | 
| * | ... | ... | ... | 
| * | info | ... | Downloading server file list... Completed | 
| * | erro | YYYY/MM/DD hh:mm:ss | Cannot start shadow copy, reason = Failed to get VM State. Error = Invalid namespace | 
| * | ... | ... | ... | 
Cause
This is a known issue with AhsayOBM version 7.15.0.8 - 7.15.0.20.
Resolution
To resolve the issue, patch the AhsayOBM client application to version 7.15.2.2 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.
